pip, Python modüllerini merkezi bir python deposundan kurmak için kullanılan bir araçtır. pip komutunu kullanırken ffi.h gcc gibi bir hata olabilir. Bu hata aşağıdaki gibi görünecektir.

Pip ffi.h Gcc Hatası
Pip ffi.h Gcc Hatası

Libffi-dev’i Kurulumu

Bu problem libffi kütüphaneleri ile ilgilidir. libffi geliştirme kütüphaneleri kurulu değilse bu hatayı alırız. Bu sorunu çözmek için Debian / Ubuntu’daki libffi-dev‘i, Redhat / Centos / Fedora’daki libffi-devel‘i kurun.

Ubuntu, Debian, Mint, Kali İçin Çözün

Libffi-dev paketini deb bazlı dağıtımlara yükleyeceğiz.

Ubuntu, Debian, Mint, Kali İçin Çözün
Ubuntu, Debian, Mint, Kali İçin Çözün

Fedora, CentOS, RedHat İçin Çözün

libff-devel paketini rpm tabanlı dağıtımlara yükleyeceğiz.

Fedora, CentOS, RedHat İçin Çözün
Fedora, CentOS, RedHat İçin Çözün

 

Pip ffi.h Gcc Hatası Infografik

Pip ffi.h Gcc Hatası Infografik
Pip ffi.h Gcc Hatası Infografik

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir